Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: ProviewR doesn't running in Raspberry

ProviewR doesn't running in Raspberry 5 months 4 days ago #11336

  • Tomas
  • Tomas's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 53
  • Karma: 0
Hello,

I try to running the ProviewR on Raspberry
Development Environment: Debian 11. ProviewR version:V5.9.0-2
Runtime Environment: Raspberry Pi OS. ProviewR version:V5.9.0-2

I already follow the "man_rpi.pdf" document to configuration. The documents is edit by V5.8
I compile the plc program. build the node and distribute to RPI. Not error. it is look good.


distribute.JPG


But when I running ProviewR with rt_ini -i in RPI. there is error.
"error when loading shared libraries: libhdf5 openmpi.so.103:cannot open shared object file: Not such file or directory"

rt_ini-i.JPG


Somebody test the V5.9.0-2 on newest raspberry Pi OS?
Thanks your help if you know how to fix it!

Best Regard
Tomas
The administrator has disabled public write access.

ProviewR doesn't running in Raspberry 5 months 3 days ago #11337

  • Tomas
  • Tomas's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 53
  • Karma: 0
Hello All,

I already fix this problem.

As the terminal mention. install the "libhdf5-openmip-103."

libhdf5-openmpi-103.JPG


After then I run rt_ini -i again. there is still library missing.
Follow the terminal mention. install the missing library "libmosquitto-dev"

libmosquitto.JPG


After then. the ProviewR running well on newest Raspberry Pi OS

ProviewR.JPG



If you meet same issue as me. Hope it will help you to fix it. B)


Best Regard
Tomas
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 1.196 seconds