Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Template object not populated in function object

Template object not populated in function object 5 months 2 weeks ago #10600

Hi,
I've created a class volume with function object configured as C-codeFo. I've defined the attributes of the class below the RtBody object in the correct order. Having saved the file the Template object that is created does not contain the layout of the class. I get
Template _O0.0.1.3:2148532224
- ObjectName Template
When saving the file I get a workbench message - Errors when saving volume: 1 error found.
The error is not specified.
This is in V5.7 Ubuntu 18.04
Any help to resolve this would be appreciated.
Stephen
The administrator has disabled public write access.

Template object not populated in function object 5 months 2 weeks ago #10602

I have found the error in cvol'MyProject'.wb_load

! %WBDUMP-E-Error Failed to get object class
Object Template $ClassLost 2148761600 01-JAN-1970 01:00:00.00

Please help to locate and restore this object
Thanks
Stephen
The administrator has disabled public write access.

Template object not populated in function object 5 months 2 weeks ago #10603

I found that Jan (user deiKruve) had exactly this problem some years ago topic #4081.
Claes suggested a possible solution to delete the $pwrp_load/'classvolumename'.dbs then delete the template object and resave. I have done this without success. I also deleted the 'classvolumename'_xtthelp.dat. Still without success.
Jan didn't report success or not but presumably it did work for him.
Is there anything else I can do?
Stephen
The administrator has disabled public write access.

Template object not populated in function object 5 months 1 week ago #10606

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 2795
  • Karma: 0
Hi Stephen,

Usually the problem is that there is an old class in the dbs-file with the same name. In that case you have to remove the dbs-file for the class volume and then start the configurator and the class editor, remove the template object and save. I suspect you didn't restart the configurator with removed dbs-file.

/Claes
The administrator has disabled public write access.
The following user(s) said Thank You: silvaphoenix

Template object not populated in function object 5 months 1 week ago #10608

Morning Claes,
Good to hear from you.
Just removing the dbs file first didn't work and I had to do a little more. I deleted everything relating to the class volume including the .wb_load files and ClassVolumeConfig, then closed the configurator and started again.
Success.
Thank you Claes, we can always count on you.
Stephen
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.514 seconds