Welcome, Guest
Username: Password: Remember me

TOPIC: some practical questions

some practical questions 2 months 2 days ago #10726

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 2799
  • Karma: 0
Hi jds,

Seems as if redcom is receiving the packets but not the plc thread. Can you check that the plc process is running in the passive node?

I've written a description on redundancy that you'll find on the document page under other documents.

/Claes
The administrator has disabled public write access.

some practical questions 2 months 2 days ago #10727

  • jds
  • jds's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 78
  • Karma: 0
Claes,

The PLC is NOT running at the secundary node. When I do a reset of the node the following is always displayed:


I thought this was normal and the PLC was waiting to take over when the primary failed.
The administrator has disabled public write access.

some practical questions 2 months 2 days ago #10728

  • jds
  • jds's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 78
  • Karma: 0
Looks like the plcthreads list is empty at the secundary node:
The administrator has disabled public write access.

some practical questions 2 months 1 day ago #10729

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 2799
  • Karma: 0
Check that the executable plc_ubuntu2_0001_plc is there on $pwrp_exe.

It should be created on $pwrp_exe on the development station when you build the secondary node, and then distributed to the secondary node.

/Claes
Last Edit: 2 months 1 day ago by claes.
The administrator has disabled public write access.

some practical questions 2 months 1 day ago #10730

  • jds
  • jds's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 78
  • Karma: 0
Yep,
there was the error: $pwrp_exe is referring to /pwrp/x86_linux while my system is a x86_64_linux type. The 64 dir exists so renamed it to x86_linux and the redundancy works.

Is there a reason the system distributes to the x86_linux dir instead of the x86_64_linux dir, checked all the, to my knowledge, settings?

Strange the the primary node was running while having the same problem ...
Last Edit: 2 months 1 day ago by jds.
The administrator has disabled public write access.
Time to create page: 2.167 seconds