Welcome, Guest
Username: Password: Remember me

TOPIC: ProviewR on Raspberry Pi

ProviewR on Raspberry Pi 2 months 3 weeks ago #11644

  • Maverick
  • Maverick's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 74
  • Karma: 0
Hi Claes,

I only installed the pwrrt package on the RPi and it was from the Terminal on the same station that I attempted to run the pwr start command... But it keeps displaying the same error. Maybe I got the wrong Raspberry Pi OS version for the version V5.8?

/Maverick
Last Edit: 2 months 3 weeks ago by Maverick.
The administrator has disabled public write access.

ProviewR on Raspberry Pi 2 months 3 weeks ago #11647

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 3048
  • Thank you received: 454
  • Karma: 125
The distibution problem is that $pwr_exe is not defined when executing a command over ssh. It should be defined in /etc/pwrp_profile but for some reason this script is not executed. You can try to add this in the beginning of .bashrc in /home/pwrp
source /etc/pwrp_profile

You can also add
alias pwr='/etc/init.d/pwr'

The definition of 'pwr' was changed in V5.8 because the startup was moved to systemd for debian, but not for raspbian, and that's why there is some mismatch. This is the old definition that I think should work.

I use to check first by starting ProviewR with
rt_ini -i &

and look for error messages. Then stop with
source pwr_stop.sh

/Claes
The administrator has disabled public write access.
The following user(s) said Thank You: Maverick

ProviewR on Raspberry Pi 2 months 3 weeks ago #11648

  • Maverick
  • Maverick's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 74
  • Karma: 0
Hi Claes,

Thanks for your answer, at least I can install the distributed package and also, run the pwr start command. But upon running the pwr start command, there are still some remaining errors.

/Maverick
Attachments:
Last Edit: 2 months 3 weeks ago by Maverick.
The administrator has disabled public write access.

ProviewR on Raspberry Pi 2 months 3 weeks ago #11651

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 3048
  • Thank you received: 454
  • Karma: 125
Hi Maverick,

What is the output if you run 'rt_ini -i'?

/Claes
The administrator has disabled public write access.

ProviewR on Raspberry Pi 2 months 3 weeks ago #11655

  • Maverick
  • Maverick's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 74
  • Karma: 0
Hi Claes,

Here's the output of running 'rt_ini -i':

rt_ini: error while loading shared librairies: libhdf5_openmpi.so.103: cannot open shared object file: No such file or directory

Installing the package 'libhdf5-dev' didn't solve it

/Maverick
Last Edit: 2 months 3 weeks ago by Maverick.
The administrator has disabled public write access.

ProviewR on Raspberry Pi 2 months 3 weeks ago #11656

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 3048
  • Thank you received: 454
  • Karma: 125
These are the archives needed for V5.9 and I think it's the same for V5.8 except maybe libmosquitto1
> sudo apt-get install -y libgtk2.0-0 libasound2 \
	libdb5.3 libdb5.3++ libsqlite3-0 librsvg2-2 g++ xterm libmariadb3 \
	libusb-1.0-0 libhdf5-openmpi-103 librabbitmq4 libmosquitto1 \
	libgstreamer1.0-0 libgstreamer-plugins-base1.0-0 \
	xterm xfonts-100dpi sudo procps

/Claes
The administrator has disabled public write access.
Time to create page: 0.481 seconds