Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Modbus RTU frame errors

Modbus RTU frame errors 1 year 5 months ago #10077

  • Coco82
  • Coco82's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Hi,

I try to communicate with a PLC, using the Modbus RTU communication. Much frames are in errors (one out of ten) : the Modbus_RTU_Slave module send the requests (not always regular) but there are only few answers.

After testing different parameters, I used a serial port analyzer to check the requests and the answers.
I found out that Proview sent the request twice, one after the other. So the slave didn't answer.
Sometimes, Proview sent only one request, and the slave answered.

Can you tell me where does the problem come from, please?

Best regards,
Jerome
The administrator has disabled public write access.

Modbus RTU frame errors 1 year 4 months ago #10081

  • benoit
  • benoit's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 153
  • Karma: 0
Salut Jerome,
Pour permettre à Claes de te répondre plus rapidement, pense à poster le maximum d'infos (vues d'écran 'paramètres objets' et vues messages Xterminal). ;)
/Ben
The administrator has disabled public write access.

Modbus RTU frame errors 1 year 4 months ago #10082

  • Coco82
  • Coco82's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Hi,

As Ben suggested, I give you more informations.
First, I give you my Modbus RTU configuration, in attachment.

I will show you frame captures, with request and answer problems, but I have to set my platform back, so I need time. Maybe next week...

Thanks to take a look to my problem.

Jerome
Attachments:
The administrator has disabled public write access.

Modbus RTU frame errors 1 year 4 months ago #10091

  • brunad
  • brunad's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 224
  • Karma: 0
Hello Jérôme.

Si j'ai bien compris le TSX est maître (client) ? IL semble quelquefois répondre en plus d'une seconde

1-Mets les tâches sur un thread de 0,1s et les scan interval sur 10

2-Essaie d'augmenter receive timeout à 3s par exemple :(

/Bruno
Last Edit: 1 year 4 months ago by brunad.
The administrator has disabled public write access.

Modbus RTU frame errors 1 year 4 months ago #10110

  • Coco82
  • Coco82's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Hi,

I made the test back, and I made screenshots, this time.
You can see the 2 cases:
  • Frame OK : Proview send the request "01 01 00 00 00 0E BD CE" only once, and the slave send the aswer "01 01 02 0 00 B9 FC". as you can see, the slave answer quickly (less than 30ms)
  • Frame NOK : Proview send the request twice, so no answer from the slave.

@Bruno : Le TSX est esclave (Modbus RTU). J'ai changé le Thread (0,1ms) et le Scan_interval (10), c'est plus stable mais j'ai des requetes toutes les 1,5s (10x0,1=1s :blink: ). Pour le Receive_timeout à 3s, ça met proview en défaut (running en rouge), donc je suis revenu à 500ms. De toute façon, l'automate repond rapidement.

Jerome
Attachments:
Last Edit: 1 year 4 months ago by Coco82.
The administrator has disabled public write access.

Modbus RTU frame errors 1 year 4 months ago #10112

  • claes
  • claes's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 2750
  • Thank you received: 371
  • Karma: 118
Hi Jerome,

It looks as if the screenshots are identical.

/Claes
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 5.171 seconds